Home > Releases > WPMU Ldap 2.9 Released

WPMU Ldap 2.9 Released

The latest version of the WPMU Ldap plugin is now available for download.  This is a minor bugfix release – see the changlog for full details.  Even though the plugin version is 2.9 – it should continue to work with the 2.8 series of WPMU.

The plugin can be download from the Sourceforge project page.  As always, I hope you enjoy it and please report any problems or suggestions you might have!

Categories: Releases Tags:
  1. February 1st, 2010 at 06:43 | #1

    Thanks for all the work you put into this plugin. When upgrading to the last release, I noticed that the plugin didn’t work when activated site-wide in /plugins/ but had to be put in /mu-plugins/

    Will this version work if installed in /plugins/ and activated site-wide on v2.9.1.1 ?

    • February 1st, 2010 at 07:26 | #2

      No – this plugin must be installed in the mu-plugins folders, and will most likely always stay there. Is there some reason why you are looking to move it?

  2. February 3rd, 2010 at 12:07 | #3

    It’s not a big deal but I don’t understand why plugin authors continue to use the /mu-plugins/ folder now that all plugins can go in /plugins/ and be activated site-wide. It’s useful when they are in the wordpress.org repository because then the auto-update alerts work, too. Also, for the site-admin, all plugins are listed together in the admin area in one place.

    Like I said though. Not a big deal. Is there a reason why you wouldn’t use /plugins/ ?

  3. March 2nd, 2010 at 15:07 | #4

    How do I troubleshoot this error message?

    ERROR: Unknown error in LDAP Authentication.

    I upgraded MU to 2.9.1 and have tried the new 2.9 LDAP plugin, to no avail.

  4. March 2nd, 2010 at 16:04 | #5

    reading all of these comments helped.. I got an LDAP browser and I was missing a ‘\’ after my lastname (e.g. CN=Lastname\, first, etc….)

  5. March 2nd, 2010 at 17:53 | #6

    Thanks for this! One issue though, I had this plugin working properly last week. Then this week I completely hosed my install and had to start from scratch from the server install an all.

    Now, I’ve tried installing both 2.9 & 2.8.4 but I receive the same results: I set up all the Authentication Options properly, and I can save the settings, but when I go to test the connection I only get pointed to a blank page. The URL looks like this “/wp-admin.php?page=wpmu_ldap_admin.functions.php” So I know it’s only working off of that file.

    I’ve checked and I have the “extension=php_ldap.dll” uncommented in php.ini. Any help would be greatly appreciated!

  6. March 3rd, 2010 at 00:26 | #7

    @Kevin
    Can you give me more detail on this? What field and the specific text you are entering. Feel free to contact me directly if preferred – http://aaron.axelsen.us/feedback

  7. March 3rd, 2010 at 00:27 | #8

    @Josh
    Have you checked the apache error log and tried enabling php errors to see whats happening? Typically a white screen indicated something is erroring out.

  8. March 3rd, 2010 at 10:23 | #9

    Thanks so much! I’m not really sure the whole technical details behind it, but somehow when I enabled error logging in PHP and created the error log file, it stopped returning a blank screen!

    You probably just helped me keep my job! Thanks again!

  9. Hudson Dunice
    April 23rd, 2010 at 10:25 | #10

    Plugin could not be activated because it triggered a fatal error.

    WPMU 2.9.2
    WPMU LDAP 2.9

  10. Hudson Dunice
    April 23rd, 2010 at 10:31 | #11

    @Hudson Dunice
    I deactivated all plugins and doesnt work

  11. Ahmed
    June 16th, 2010 at 01:47 | #13

    @Aaron Axelsen
    I know but there is no cofiguration page for the plugin when i put it in mu-plugins folder. any way i will reinstall the server again and see where i get.

  12. Aaron Axelsen
    June 16th, 2010 at 06:28 | #14

    It sounds like maybe you got a bad checkout from the repository – try the following zip: http://tuxdocs.net/files/wpmu_ldap_3.0_beta.zip Extract the contents into mu-plugins and see if that makes any difference

  13. Ahmed
    June 16th, 2010 at 08:29 | #15

    @Aaron Axelsen
    hi
    now i have everything working but…. where or how can i get to the page where i configure the ldap settings. i cant find it anywhere and there is not edit link under the plugin.

  14. Aaron Axelsen
    June 16th, 2010 at 08:32 | #16

    Under “Super Admin” you should see an “ldap options” page that contains all the settings

  1. No trackbacks yet.